Subversion on Lacie Network Space vs1

Post any question, feedback you have regarding the Lacie Network Space vs 1 in this forum

Subversion on Lacie Network Space vs1

Postby armoor » Mon Nov 03, 2014 3:50 pm

Hello! I'm fairly new to linux and I'm struggling to set up subversion on Lacie Network Space vs1.

I've installed the following files:-
subversion-1.5.1.tar
openssl-0.9.8h-r1.tbz2
db-4.6.21_p3-r1.tbz2

I can create a repository at the command line, so the files I've installed appear to be working correctly, but I cannot access the svn server remotely.

I'm not sure if I need to amend the apache configuration file or something.

Any help will be much appreciated.

Many thanks (in advance)

Ian Norman
armoor
 
Posts: 2
Joined: Sun Oct 26, 2014 5:57 pm

Re: Subversion on Lacie Network Space vs1

Postby Jocko » Mon Nov 03, 2014 6:58 pm

Hi armoor.

What firmware do you use ? (Lacie or fvdw-sl).

armoor wrote:I've installed the following files:
openssl-0.9.8h-r1.tbz2
With fvdw-sl, OpenSSL/1.0.1g is already present :tapfoot
User avatar
Jocko
Site Admin - expert
 
Posts: 7170
Joined: Tue Apr 12, 2011 4:48 pm
Location: Orleans, France

Re: Subversion on Lacie Network Space vs1

Postby armoor » Mon Nov 03, 2014 11:50 pm

Thank you for your reply Jocko.

I'm using firmware fvdw-sl.
I installed the openssl-0.9.8h-r1.tbz2 because the subversion-1.5.1.tar expected the 0.9.8 dll.
svnadmin wouldn't run until that version was installed.

I'd install a later version of subversion if I could track one down.
armoor
 
Posts: 2
Joined: Sun Oct 26, 2014 5:57 pm

Re: Subversion on Lacie Network Space vs1

Postby Jocko » Tue Nov 04, 2014 5:09 pm

hi armoor,

So you use the alternative firmware.
Where did you find your packages (from buffalo.nas-central.org) ? because I am pretty sure that these packages can not run with our firmware. :mrgreen:

Other issue, if you want to use svn through the apache server, you need also an additional module mod_dav_svn but with version 1.5, this one can not work with our apache version 2.4.7.
So if you succeed to install subversion 1.5, you can use it only with the protocols svn:// or svn+ssh.

I assume that you know this link: http://svnbook.red-bean.com/en/1.5/index.html. See chap 6 to configure the svn server. ;)

Note: as writing previously, OpenSSL/1.0.1g is already present but also the library libdb (version 4.2 and 5.2). So fvdw may compile directly subversion with a more recent version...
User avatar
Jocko
Site Admin - expert
 
Posts: 7170
Joined: Tue Apr 12, 2011 4:48 pm
Location: Orleans, France


Return to Lacie Network Space vs1

Who is online

Users browsing this forum: No registered users and 1 guest