Hab mein username/passwort auch vergessen

Post any question, feedback you have regarding the Philips SPD8020 in this forum

Hab mein username/passwort auch vergessen

Postby gertschi » Sat Nov 16, 2013 12:22 am

Dear fvwd,

leider ist es nun auch mir passiert: kann mich über das Webinterface nicht mehr auf meine SPD8020 einloggen (hab da vor langer Zeit was verändert und leider vergessen :?:) .
Kannst du mir da bitte auch helfen, mit Linux (Putty) kenn ich mich an sich ganz gut aus.

Meine aktuelle Firmware ist (wahrscheinlich) spd8020-fvdw5-0-20092009.bin

Vielen Dank wenn du mir helfen könntest :applause

gertschi
gertschi
 
Posts: 4
Joined: Sat Nov 16, 2013 12:04 am

Re: Hab mein username/passwort auch vergessen

Postby fvdw » Sat Nov 16, 2013 10:30 am

Hi gertschi

You are still running an old version attached a small script you can try to use (think it will be fine but I never tried on such an old version)

to restore the password to the default:
- Unzip the file in your public share
- in putty window give this cmd

Code: Select all
php /share/1000/public/restore_adminpassword.php


if it's ok you should get this kind of output

Code: Select all
   root@xxxx # php restore_adminpassword.php
    original password:$1$xxxxxxxxxxxxxxxxxxxxxxxxxiUw0s1
    passwd saved in the nas database :$1$sxGBHQaX$kINxDTfpACgURLzjy9FwW0
    AuthUserFile line is 'admin-nas:$1$sxGBHQaX$kINxDTfpACgURLzjy9FwW0'


---edit---
file available here :http://www.plugout.net/viewtopic.php?f=7&t=1971
User avatar
fvdw
Site Admin - expert
 
Posts: 8472
Joined: Tue Apr 12, 2011 2:30 pm
Location: Netherlands

Re: Hab mein username/passwort auch vergessen

Postby gertschi » Sat Nov 16, 2013 11:17 pm

Hi fvdw,

thanks because of your quick response!

I'll try your script as soon as possible but just now I have some other troubles because my SP8020 has fixed IP (192.168.1.2) and some days ago I got some new cablemodem-router from my provider with an other segmentation (192.168.0.1 .....).
But this is an other construction area :fists

So, now I can connect to the SP8080 via udp and also via putty (ssh), but in putty-session I have login with username/password - same prob like in webif??
Any idea (I did copy your *.php script into the public folder)
You do not have the required permissions to view the files attached to this post.
gertschi
 
Posts: 4
Joined: Sat Nov 16, 2013 12:04 am

Re: Hab mein username/passwort auch vergessen

Postby fvdw » Sun Nov 17, 2013 9:53 am

for ssh login via putty
username: root
password: giveit2me

(unless you changed those defaults as well)
User avatar
fvdw
Site Admin - expert
 
Posts: 8472
Joined: Tue Apr 12, 2011 2:30 pm
Location: Netherlands

Re: Hab mein username/passwort auch vergessen

Postby gertschi » Sun Nov 17, 2013 6:16 pm

Thx, root-login is ok .

Starting your script results in

Code: Select all
/share/1000/public # php ./restore_adminpassword.php
PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/lib/php/extensions/pdo.so' - /usr/lib/php/extensions/pdo.so: cannot open shared object file: No such file or directory in Unknown on line 0
original password:$1$fWRMqCSe$KtfdY3hUMQTYxNLnXFujS1
passwd saved in the nas database :$1$EbTeGaSi$z6EetqI/FEoCS8NrcQ3gc1
AuthUserFile line is 'ADMIN:$1$EbTeGaSi$z6EetqI/FEoCS8NrcQ3gc1'
/share/1000/public #


I think my firmware is really to old (but was working without any troubles - you know "never change a running system" ;))
gertschi
 
Posts: 4
Joined: Sat Nov 16, 2013 12:04 am

Re: Hab mein username/passwort auch vergessen

Postby fvdw » Sun Nov 17, 2013 9:47 pm

yes its old but the output of the script seems ok it has restored the password
You need to reboot and then you should have again the default password "admin" for accessing the webinterface
User avatar
fvdw
Site Admin - expert
 
Posts: 8472
Joined: Tue Apr 12, 2011 2:30 pm
Location: Netherlands

Re: Hab mein username/passwort auch vergessen

Postby gertschi » Mon Nov 18, 2013 9:43 pm

reboot, yea!

Sorry that I was so stupid to think about this by myself :hammerhead

Now login is successful, I'm very happy now!!

Dear fvwd, thank you very much for your patience :thumbup

gertschi
gertschi
 
Posts: 4
Joined: Sat Nov 16, 2013 12:04 am

Re: Hab mein username/passwort auch vergessen

Postby ercev » Sun Jun 01, 2014 9:47 pm

damn i am so unlucky. i tried this one too but i couldnt make it again. how can i reset to default configuration for wegui. like admin // admin??

ok i found my problem...

the admin account name is "admin-nas" without quotes.damn....

viewtopic.php?f=5&t=1448#p10324

please guys could you make a new topic and write down what is the version user name and passwords.it took my 3 hours to find out.
ercev
 
Posts: 6
Joined: Wed Jun 26, 2013 1:28 am


Return to Philips SPD8020

Who is online

Users browsing this forum: No registered users and 1 guest